MS Teams - Intermittent Call Initiation Issues

Incident Report for Dubber

Postmortem

After investigation, and liaising with Microsoft, Microsoft confirmed they experienced a power event in the North Europe region, which impacted their services in this region.

Microsoft have confirmed that power and services were fully restored.

Posted Apr 01, 2025 - 15:18 UTC

Resolved

This incident is now resolved and MS Teams calls are now initiating as expected.
Posted Apr 01, 2025 - 10:03 UTC

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 09:23 UTC

Investigating

Dubber is aware of an issue intermittently impacting MS Teams call initiation which we are currently investigating. Please note recording is not impacted.
Posted Apr 01, 2025 - 09:22 UTC
This incident affected: Great Britain Availability (Great Britain (UK1) - MS Teams Recording).