Global Cloudflare Issue Impacting Dubber Portal Access

Incident Report for Dubber

Resolved

Dubber has continued to monitor our portal interfaces and we are seeing no issues accessing Dubber portals and we are satisfied that Cloudflare has resolved the issue and this issue is being closed.
Posted Nov 18, 2025 - 17:44 UTC

Monitoring

Dubber are aware of a Cloudflare incident which is impacting access to the Dubber portal.

Cloudflare are aware of the issues and are working to resolve the problems.

Dubber will periodically provide updates on the Cloudflare issues which can also be seen here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 14:21 UTC
This incident affected: United Kingdom Availability (United Kingdom (UK) - Dubber Portal), Great Britain Availability (Great Britain (UK1) - Dubber Portal), United States Availability (United States (US) - Dubber Portal), Canada Availability (Canada (CA) - Dubber Portal), and Europe Availability (Europe (EU) - Dubber Portal).