Investigating issues with US Dubber Accounts

Incident Report for Dubber

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 06:16 UTC

Monitoring

We found the problem and have taken corrective action. We can see call recordings resuming in the US and we will continue to monitor the nodes to verify this issue has been rectified.
Posted Jul 16, 2025 - 22:04 UTC

Update

Dubber is continuing to work to identify the issues impacting the US Dubber portal accounts. We will identify and remedy the issues as swiftly as possible
Posted Jul 16, 2025 - 21:48 UTC

Investigating

We are investigating reports that recordings have stopped updating in the US Dubber portal. We will provide more detail when this has been identified.
Posted Jul 16, 2025 - 21:16 UTC
This incident affected: United States Availability (United States (US) - Dubber Portal).