Microsoft Teams Pause & Resume App Outage - All Regions

Incident Report for Dubber

Resolved

A fix has been deployed to all regions, the browser version of the Pause and Resume App is now functioning as expected.
Posted Feb 25, 2026 - 11:43 UTC

Investigating

We are currently investigating an issue affecting Dubber's Microsoft Teams Pause & Resume App. The issue is not impacting the desktop client however the browser version is unavailable.

Call recording is NOT impacted by this incident, only the Pause & Resume app.
Posted Feb 25, 2026 - 00:17 UTC
This incident affected: Great Britain Availability (Great Britain (UK1) - MS Teams Recording, Great Britain (UK1) - Dubber Portal, Great Britain (GB) - Call Playback, Payment Services), United States Availability (United States (US) - MS Teams Recording, United States (US) - Dubber Portal, United States (US) - Call Playback), Australia Availability (Australia (AU) - MS Teams Recording, Australia (AU) - Dubber Portal, Dubber Insights - AU, Australia (AU) - Call Playback), Canada Availability (Canada (CA) - MS Teams Recording, Canada (CA) - Dubber Portal, Canada (CA) - Call Playback), Europe Availability (Europe (EU) - MS Teams Recording, Europe (EU) - Dubber Portal, Europe (EU) - Call Playback), Singapore Availability (Singapore (SG) - MS Teams Recording, Singapore (SG) - Dubber Portal, Singapore (SG) - Call Playback), Japan Availability (Japan (JP) - Dubber Portal, Japan (JP) - Call Playback), United Kingdom Availability (United Kingdom (UK) - Dubber Portal, United Kingdom (UK) - Call Playback), and Sandbox Availability (Sandbox (SBOX) - MS Teams Recording, Sandbox (SBOX) - Dubber Portal, Sandbox - Call Playback).