US and Canadian Dubber Portal Login

Incident Report for Dubber

Resolved

This was just a limited issue and has been fully resolved. US and CA portals can be accessed with no issues.
Posted May 26, 2026 - 18:45 UTC

Update

Dubber is continuing to investigate the login issues for US and Canadian Dubber portals.
Posted May 26, 2026 - 18:27 UTC

Update

We are continuing to investigate this issue.
Posted May 26, 2026 - 17:53 UTC

Investigating

Dubber is currently investigating an issue logging into the US and Canadian Dubber Portal. We will investigate this and resolve as quickly as possible.
Posted May 26, 2026 - 17:53 UTC
This incident affected: United States Availability (United States (US) - Dubber Portal) and Canada Availability (Canada (CA) - Dubber Portal).