Issues Accessing Insights Dashboard - US Region

Incident Report for Dubber

Resolved

We had a minor issue that limited access to our Insights dashboard in the US region briefly and this has been corrected and is now back in full operation.
Posted Jul 01, 2025 - 18:44 UTC

Investigating

We are currently investigating an issue accessing the Insights dashboard in the US Dubber portal. We are aware of this and will be identifying and correcting the issue. Will update. This appears to be limited to the US Region only.
Posted Jul 01, 2025 - 17:48 UTC
This incident affected: United States Availability (United States (US) - Dubber Portal).