Delayed Recordings Ingestion in US Region

Incident Report for Dubber

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 17:14 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 08, 2025 - 17:14 UTC

Identified

The issue has been identified and Dubber is working towards a resolution.
We can confirm that all call records have been captured, there have been no loss of call recordings.
Posted Jul 08, 2025 - 16:02 UTC

Update

We are continuing to investigate this incident. We will provide further updates when we have them.
Posted Jul 08, 2025 - 15:13 UTC

Investigating

We are aware that some customers in the US Region are experiencing delaying in call recordings being available in the Dubber portal. We are investigating this incident and will provide further details as we have them.
Posted Jul 08, 2025 - 14:46 UTC
This incident affected: United States Availability (United States (US) - Call Playback).